Twitter | Search | |
ゆう@CW用
独り言が基本の脳内放出実験アカウント(CardWirth用)→詳細 お知らせ 汎用 /cwNowUp
12,885
Tweets
144
Following
191
Followers
Tweets
ゆう@CW用 14h
Replying to @tukumo_fast
ありがとうございます。原因まで特定できれば良かったんですが、残念です。。
Reply Retweet Like
ゆう@CW用 14h
Replying to @simoom_cw
データバージョンが4よりも古いこと、プラス何かの要因がありそうなんだけどな。例えば、コンテントの並びとか。しかし検証しようがないので、これにて終了。
Reply Retweet Like
ゆう@CW用 14h
現象そのものについては、モーメントにまとめました。:見えざる者の願い」のスキル入手部分が、特定のエディタでだけ上手く読めない話
Reply Retweet Like
ゆう@CW用 14h
金狼亭更新)メモ箱更新/「私家版エンジン関連情報」更新。CWXEditorがデータバージョン4以外の公式フォーマットの取り扱いを想定していない可能性がある件と、その対策について。:カードワース シナリオデータの互換性(←データVer,4の項の最後辺り)
Reply Retweet Like
ゆう@CW用 16h
そうだな、互換性関連の記事にちょっとだけ追記しよう。そうしよう。
Reply Retweet Like
ゆう@CW用 16h
Replying to @suiun3319
ああ! ありましたね、思い出しました。そうか、全くない話でもないのですねぇ。
Reply Retweet Like
ゆう@CW用 16h
Replying to @cw_shuto
うーん、確かに。悩ましいですね。いつか分かることを祈りますか。。。
Reply Retweet Like
ゆう@CW用 16h
Replying to @simoom_cw
そういや、幻のデータバージョン3シナリオは、現存しているのだろうか。CardWirthEditor1.20公開時の開発履歴に「データバージョン3対応」の表記があるものの……
Reply Retweet Like
ゆう@CW用 16h
Replying to @simoom_cw
まあ、20年以上前に作っていたシナリオを、いま完成させようという人が存在するのか分からんけどなー。
Reply Retweet Like
ゆう@CW用 16h
Replying to @simoom_cw
あ、いや。そうか。機会はそうそうないだろうけれど、引っかかった人にとっては影響大ありだな。XEditorで一度でも上書きすると、その結果生じるデータバージョン4のシナリオデータで、この参照なし状態が確定してしまうわけで。
Reply Retweet Like
ゆう@CW用 16h
Replying to @cw_shuto
バグか仕様か分かりませんが、現在1.20時代よりも古いシナリオを編集する機会はそうそうないでしょうし、影響はごく小さいと思われます。開発陣に突撃して、どちらなのか明らかにするほどのことでもなさそうでは。
Reply Retweet Like
ゆう@CW用 16h
Replying to @cw_shuto
あわわわありがとうございます!(実は期待してt) データバージョン4用の公式もしくは公式ベースのエディタで問題ないことを考えると1.15エディタがバグっているのでもなさそうだし……やはりシナリオ自体は正常で、XEditorがデータバージョン4以外の編集を想定してないというところでしょうか。
Reply Retweet Like
ゆう@CW用 retweeted
大地の子 Jul 5
6年前に作成したCWシナリオ「死こそ我が喜び」を、Ver-2.00に更新しました。  前Verまでは技術的な手違いでNEXT専用シナリオとなっていましたが、今回の更新で1.20以降の全エンジン対応版となっています!  その他、多数のバグ修正及び仕様改善を行いましたので、是非お楽しみください!
Reply Retweet Like
ゆう@CW用 Jul 5
Replying to @simoom_cw
(承前)たまたまデータが壊れていた可能性を潰すため、「内容には手を触れずにCWEditor1.15で上書き→CWXEditor7.3で開く」──要するにデシナリオータバージョンを2に保ったまま再保存したら修復されないかを試したいのだけど、CWEditor1.15を、持ってないので無理だったー。
Reply Retweet Like
ゆう@CW用 Jul 5
Replying to @simoom_cw
(承前)問題のシナリオをCWEditor1.25で開き、内容は何も触らずに上書きボタンを押して閉じたあと、CWXEditor7.3で開くと、技能取得の参照はきちんと読み取れた。このとき、技能取得コンテントは全く触っていない。つまり、技能を指定し直して不具合が解消したわけではない。(続く)
Reply Retweet Like
ゆう@CW用 Jul 5
Replying to @simoom_cw
公式シナリオ「見えざる者の願い」(シナリオデータバージョン2)の「蜘蛛の糸」入手部分について: そのまま開いたとき ・CWE1.20、CWE1.25、WB1.1.38、WB1.2.28→参照OK ・XEditor7.3→参照なし CWE1.25で一度上書きして開いたとき(内容は触ってない) ・全てのエディタ→参照OK (続く)
Reply Retweet Like
ゆう@CW用 Jul 5
Replying to @cw_shuto
現存している公式エディタは全てデータバージョン4シナリオ作成用なので、データバージョン0とか2とかが動作対象外でも、ほとんどの場合問題ないでしょうしね。
Reply Retweet Like
ゆう@CW用 Jul 5
Replying to @cw_shuto
これが本当に旧仕様シナリオへの対応の問題だった場合、XEditorの付属テキストなどにデータバージョン4専用の記述がなければ、バグ的仕様の領域になりますかね。しかし、シナリオのデータバージョンが関係あるとしても、それのみに依存しているわけでもなさそうです。
Reply Retweet Like
ゆう@CW用 Jul 5
Replying to @simoom_cw
元ネタ話の技能は、中身が違うが名称と解説が同じ所謂「同一と見なされるカード」。最近のエンジンだと、先にリューンで買ったものを荷物袋や宿のカード置き場に持っていると、見えざる者の願い版を入手しても元からあるやつで上書きされてしまったりするんだよな。
Reply Retweet Like
ゆう@CW用 Jul 5
XEditorのバグというよりデータバージョン2のシナリオへの対応が甘いのでは……と思ったが、同じくデータバージョン2の「墓守の苦悩」では問題なさげだしなあ。データバージョン0の「機械仕掛けの番犬」は、参照箇所がないので分からなかった。
Reply Retweet Like