Twitter | Search | |
Marco Arment Jun 17
Another day, another fight with Homebrew to do very basic things that worked perfectly from the same script TWO MONTHS AGO, and of course, now, it works differently and all of the previous packages are broken.
Reply Retweet Like
John Gruber Jun 17
Ruby’s not in Catalina?
Reply Retweet Like
Venkat Jun 17
Check under Deprecations
Reply Retweet Like
John Gruber Jun 17
And the exact verbiage here suggests that Ruby/Python/Perl will not be installed by default, but will be available in a supported fashion (much like Xcode command-line tools):
Reply Retweet Like
John Gruber
It might last “forever”. I suspect they’re removing them by default only as a security measure, not because they’re any less interested in supporting them for those who use these languages. Fingers crossed.
Reply Retweet Like More
John Gruber Jun 17
I don’t think there’s anything outdated about these languages, any more so than anything else in the standard Unix command-line toolset.
Reply Retweet Like