Twitter | Search | |
Filip Matijević
Finally managed to get PowerVR SGX (TI 4.10.00.01) drivers to work on with v4.15-rc3 kernel &
Reply Retweet Like More
Sam Dec 26
Replying to @fi1ippz
Would it be possible to do the same on SGX540? By the way I love you
Reply Retweet Like
Filip Matijević Dec 26
Replying to @SamZaNemesis
Seems not with these: In theory, you could apply similar patches to older drivers to get them running on new kernels.
Reply Retweet Like
NeKit Dec 26
Replying to @fi1ippz @SamZaNemesis
Are those patches avaliable somewhere? Would love to try this with Droid 4. There were no musl/glibc incompatibility for userspace libs?
Reply Retweet Like
Filip Matijević Dec 27
Patches/info: Not all demos work due to musl/glibc issues with unresolved symbols, but libc6-compat and gcompat packages makes pvrsrvctl and a couple of demos runnable
Reply Retweet Like
NeKit Dec 27
Replying to @fi1ippz @SamZaNemesis
Does it work with omapdrm or requires legacy fb driver?
Reply Retweet Like
Filip Matijević Dec 27
omapdrm - but kernel needs a couple of small patches that I forgot to include. I'll post those once I get back home.
Reply Retweet Like
ɹǝdsɐſ Dec 28
Replying to @fi1ippz
If these Patches work on the N9's SGX530, shouldn't they also work similarly on the N900? It could be crucial on getting a functional desktop working with acceleration, especially for the weaker hardware on the N900.
Reply Retweet Like
Filip Matijević Dec 28
Replying to @jja2000
Pure guesswork: * part of the patch is specific to N9 (omap3630 folder), those for N900 are the ones in omap3 folder * N900 has SGX core revision 1.2.1 (TI calls those ES3.x) while N9 has SGX core 1.2.5 (ES5.X). In any case everything needed should be in there...
Reply Retweet Like
sehh Jan 5
Replying to @fi1ippz
Hi - points to which appears defunct.
Reply Retweet Like
Alexxxl Jan 27
Replying to @fi1ippz @Van_ess0
Какая практическая польза ??!
Reply Retweet Like