Twitter | Search | |
Essential Mar 21
Apologies, mis-tweeted a moment ago. We're in the process of certifying for 5.0 which should be completed in a couple weeks. We'll correct our website to avoid confusion. Thanks again!
Reply Retweet Like
VanCity Kurt Mar 21
Replying to @essential
Didn't realize that required certifying. Does that mean that currently the phone will not work with a Bluetooth 5.0 device?
Reply Retweet Like
Essential
Just heard that Bluetooth 5.0 certification is complete. It's already in the 8.1 build so if you have any 5.0-ready devices give it a try. :)
Reply Retweet Like More