Twitter | Search | |
Ⓜ MuscleNerd
the iPad2-wifi is fine (if you have 4.3.3 blobs) since it won't error out on the baseband step during downgrade
Reply Retweet Like More